#4973092
Hi,

When you made your pack and did the frame for mounting it, did you happen to make a note of how long the pieces had to be etc? And what size pvc pipe did you use to make the frame.

Did you use straps from a backpack or did you use Alice frame straps? I'm on the finishing straight with my pack now but it's the 80% one that I got from your github. I don't think it'd look right on a full size Alice pack.

Thanks,

Brett
#4973102
This post may contain an affiliate link that helps support GBFans.com when you make a purchase at no additional cost to you.

I used 3/4 inch pvc pipe and fittings. I bought some straps off of Amazon.

https://www.amazon.com/gp/product/B000SKLK6A

it was a while ago so you'll probably have to find another. I don't have the exact measurements. I pretty much winged it and tried to make it fit my son's back so the spots that touch the back where near his shoulders and the back brace area on the lower back. The frame I built several years ago no longer fits him now that he's 12. I would probably try to mount it to a real alice frame now if I was doing it again. The home built one was not very comfortable for him.
#4973105
BrettRogersUK wrote: October 4th, 2022, 9:54 am Hi,

When you made your pack and did the frame for mounting it, did you happen to make a note of how long the pieces had to be etc? And what size pvc pipe did you use to make the frame.

Did you use straps from a backpack or did you use Alice frame straps? I'm on the finishing straight with my pack now but it's the 80% one that I got from your github. I don't think it'd look right on a full size Alice pack.

Thanks,

Brett
The spirit packs are about 80% scale and look fine on an Alice frame :)
#4973106
BrettRogersUK wrote: October 4th, 2022, 9:54 am Hi,

When you made your pack and did the frame for mounting it, did you happen to make a note of how long the pieces had to be etc? And what size pvc pipe did you use to make the frame.

Did you use straps from a backpack or did you use Alice frame straps? I'm on the finishing straight with my pack now but it's the 80% one that I got from your github. I don't think it'd look right on a full size Alice pack.

Thanks,

Brett
Lost wax has an awesome guide on how to make an Alice frame out of PVC. Maintains the shape and look of an Alice frame too. You can just scale it down to 80% and it’ll look right.


This is what I plan to do for my spirit pack as I don’t look how it looks on a standard sized Alice frame.
#4973107
jonogunn wrote: October 4th, 2022, 5:30 pm
BrettRogersUK wrote: October 4th, 2022, 9:54 am Hi,

When you made your pack and did the frame for mounting it, did you happen to make a note of how long the pieces had to be etc? And what size pvc pipe did you use to make the frame.

Did you use straps from a backpack or did you use Alice frame straps? I'm on the finishing straight with my pack now but it's the 80% one that I got from your github. I don't think it'd look right on a full size Alice pack.

Thanks,

Brett
Lost wax has an awesome guide on how to make an Alice frame out of PVC. Maintains the shape and look of an Alice frame too. You can just scale it down to 80% and it’ll look right.


This is what I plan to do for my spirit pack as I don’t look how it looks on a standard sized Alice frame.
I might do this. The thought of making it out of pvc pipe appeals to me. I can't find an alice pack in the UK less than £100. So this will be the way to go I believe. I've got the plans for the original alice pack from Stefan otto. I will look for the lost wax one though.

Thanks,

Brett
#4973108
BrettRogersUK wrote: October 4th, 2022, 5:34 pm
jonogunn wrote: October 4th, 2022, 5:30 pm

Lost wax has an awesome guide on how to make an Alice frame out of PVC. Maintains the shape and look of an Alice frame too. You can just scale it down to 80% and it’ll look right.


This is what I plan to do for my spirit pack as I don’t look how it looks on a standard sized Alice frame.
I might do this. The thought of making it out of pvc pipe appeals to me. I can't find an alice pack in the UK less than £100. So this will be the way to go I believe. I've got the plans for the original alice pack from Stefan otto. I will look for the lost wax one though.

Thanks,

Brett
Forgot to post the link for you:



The important thing is using his technique which is genius
CountDeMonet liked this
#4973830
I have and Issue with my Bargraph I initially had it at a 10 led and got a MOD wand and changed it to a 15 led like Counts. It works on idle doing its standard animation. Then when i fire it seems to wor just fine but when i release it will leave a random led on the 5 led set of the bar graph. Each time its a different one. It’s like it won’t reset the leds in that set. However when i repress the fire button it will go away and restart the animations but of course leave one on again once i stop. Any one have a clue to what might be happening.?
#4978317
Hey Eric i wanted to ask you in your code am i able to switch the theme and the power switch from d5 theme sw, d6 startup sw to d13 and D8 the reason i am doing this is to add a rumble motor with a potentiometer utilizing d5 and d6 that uses PWM. D5 will be the new fire button D6 will connect to a resistor ,transistor ,diode, and cap to the motor. A6 will be used for the potentiometer. i have included a schematics and the code. i haven’t changed the original code yet i am not sure where to place it?
thanks
Ed

// inputs for switches and buttons
const int FIRE BUTTON
= 8;
const int Relay pin = 13;

void setup (){
// inputs for switches and buttons
// set the modes for the switches/buttons
pinMode (FIRE BUITON, INPUT) ;
digitalWrite (FIRE BUTTON, HIGH) :
pinMode (Relay pin, OUTPUT) ;
}
void loop ()
{
if (digitalRead (FIRE BUTTON)==LOW);{
digitalWrite (Relay pin, HIGH) ;
}

else {
digitallrite (Relay pin, LOW);
}

}
Image
#4978923
The setup is pretty simple. You would just put that where the other pins are initialized. For detecting the fire and end of fire events you would look

here for the start of the firing sequence
https://github.com/CountDeMonet/Arduino ... h.ino#L328

and here for the end of it
https://github.com/CountDeMonet/Arduino ... h.ino#L372

Hope that helps
#4979711
2wED1 wrote: February 16th, 2023, 2:46 pm Awesome sir thanks also, Also is it possible to separate the light sequence in the wand, for instance turning on a switch to just power the graph and hat lights and trigger a sound. Another switch to just power the vent light and trigger a power up sound ?
Sorry, I saw your note but forgot to finish my response. Yes, it is possible to do what you want. The wand lights are handled with this variable

wandLights

I wrote helper functions to easily allow changing the lights. Search for

setWandLightState(3, 0, 0); //set sloblow red

which will give an example of how to use it.

You can also add switches but that will require you to update the code to handle it and the new sequence.
#4993036
Hi I was haveing problems with the arduino because it worked when it was all on the bread board but since then I’ve been soldering it together and was wondering if I house the arduino in the wand are the out puts of the arduino getting thinned when they go through the 6.5 feet of 22 gauge wire the neo pixels and sound board are just not detecting them. 2 does the whole thing still work if you don’t have everything connected say you have the switches and the pack electronics but not the bar graph or sound board. 3 the neo pixels that I have used to work on the bread board but after I soldered them together they just flash random colors is this do to the long wires? Or they Broke after I soldered them together or is it something else entirely?
#4993092
I ran into similar issues when I was building this. I tried different thicknesses of wires and different ways of shielding them but could not get a stable connection from the arduino in the wand to the sound board and neopixels in the pack. I did find that I could still control the lights in the wand if I put the arduino in the pack. I'm guessing the distance is too much for the power of the arduino but there were also serious shielding issues and cross talk.

The second item, if you are using the full code with bar graph then it is going to look for the io board on startup and not allow it to proceed if not found. You can comment out the initialization code for the io board and everything else should function.

If the neopixel worked before soldering then I would double check everything. Maybe reflow the solder. Could be a weak connection somewhere
#4993597
Thank you so much it finally works now I’m not quite sure what was wrong because I tried placing a separate battery in the wand but it still didn’t work but when I moved the arduino to the back pack it worked perfectly. I also was having an issue with the bar graph module but that’s seems to work now too thank you!
CountDeMonet liked this
#4994569
I never got to the point of troubleshooting the communications issues. I remember seeing a pretty significant power drop from the pack to the wand but that was good enough for the neopixels. I never did try to get the io board to work as my wand was smaller and couldn't fit the bargraph. The spark fun board only requires 3v so I'd check what you are seeing at board there. I'm going to guess it's still above 3v. If that is the case you may be having some cross talk occurring. That was what was appearing to happen with the audio board when I was controlling it from the wand. All of the data the Arduino was seeing from the board was junk over distance with the led's running
  • 1
  • 21
  • 22
  • 23
  • 24
  • 25
Proton Props UK

Hey guys, I just wanted to give a quick update on […]

Ecto Containment Unit

First off awesome work!!! second of all where did […]

https://i.imgur.com/cMwtW9y.jpg Where do th[…]

Greetings from Montana

Hey and welcome