Talk about the your favorite Ghostbusters Collectibles from Mattel, Kenner, and more.
#4806429
I picked one up pretty early on. It worked fine for a few days of pretty minor use/playing around. Then the barrel-extend feature seemed to glitch up. It would sometimes extend as soon as I turned the wand on, and sometimes not retract.

I returned it, but opted for the refund instead of another one, worried I'd run into more problems sooner or later. If I had my way, I wish they'd either remove the barrel-extend feature altogether or maybe just make it spring loaded instead of motor driven.

Just wondering if anyone else here had the same issue, or others? Because to be honest, the GB bug is biting again and I'm halfway considering taking a chance on another one...
#4807588
Mine was the same way. I put in a fresh set and it worked muchhh better. And the tip would not extend fully all the time. So I pulled it up one time and it clicked. Worked perfect ever since
#4831669
I got mine this past Christmas and it's having the same intermittent issue with the barrel. I don't think it's a battery issue,that's the first thing I checked when mine started acting up. It started about a week after getting it and I only have used it once in a while. I'm thinking the rumbler feature may be knocking the plastic gears or extender push rod somewhat out of alignment every so often. Then when you pull the barrel out manually it must realign things. Needless to say my wife was quite unhappy with this after having paid so much for it. We were going to return it for exchange but after having read up on this it seems to be a frequent problem. I'm thinking design flaw.
#4848173
Hi Guys, just got my second matty wand for the kids and its glitchy like the first.

Barrel tip extends fine every time but often stops on return.

I followed the threads here in terms of batteries being low and I change them and it works ok for a bit but I just dont buy that being the issue. I mean yeah ok the wand uses juice but when the wand stops extending theres still plenty of action in the rumble motor when im firing it and I mean lots of bouncing so it cant be low battery must be mechanical.

So i played around with them a bit and found if I turned the wand on its sides or upside down... in and out like butter everytime, but when returned to normal position it locks on the return and I have to hand pop it back in.

After some observations I noticed when in the standard position often when the tip extended Id feel a little ratchet at the end of the movement cycle and that often corresponded to the tip not being able to return. However a quick nudge of the tip or a slight shake and it did return ok - however leave it a little too long and it wouldnt so Im guessing the motor movement stops after x seconds and a jiggle caused it to slip back into gear while it was still in movement cycle...

Ok so where Im getting to with this is that something was happening in the regular upright position to jar the tube as it extended out almost like it had gone too far and had slipped a gear. I then noticed if I kept a finger along the tube as it extended it would return everytime so I am on the right thought that somethings slipping or catching - perhaps on extension its too fast and something internals missed a ratchet or its caught on a lip.

So rather than having to stand there with my finger out to steady the tube I folded a piece of paper to make a very small wad and put that into the tube next to the want tip - you will notice that inside that outer tube there is 4 little bumps at 12, 3, 6 and 9 oclock - I put the folded paper just off centre at 6 oclock and that elevated the tube upward whereas on full extension it was often slightly down.

Now everytime I extend or retracts its fine - so my thinking that a common issue on the fail to return is mechanical not power based. - Im guessing the action of me flipping the wand over and replacing the batteries was effectively repositioning the gears and allowing it to kick start - so a red herring suggestion to change the batteries.

My next fix is to replace the little bit of paper with maybe a clear plastic wad but I think ive solved the problem on my 2 wands - maybe it will help other people.
#4848191
I bought two. One worked perfectly out of the box. The second one the tip was slow to extend in and out at first. They had been sitting in a warehouse for over a year until I took delivery though.

But if you push and pull it yourself it gets greased up and works flawlessly afterwards.

Only trouble I had was the clippard didnt sit flush on one of mine, I may take it apart and reseat it or glue it whatever.
#4884422
Mine's been having a completely different issue.
At first, operation was completely normal and no barrel issues to be found. After a while though, as soon as I power it up and press the activate button, my wand would restart! Like I was powering it back up. Startup sound would play, lights would flash, and the barrel would retract. Then it started doing the restart cycle during firing.
At first it would only do it once in a while and after a while (a few months) it started happening more often. The startup effect would also repeat.
We tore it completely apart and found that the cable assembly going to the AUX jack in the rear of the handle had been pinched during assembly and one of the wires was almost completely cut, barely making contact so we replaced it.
Because of this issue, I think I blew out my first Matty adapter board with sound from Spongeface and now that the cable assembly's been replaced, the second board seems to be holding up just fine but the restarting issue is still sticking around, even with a fresh set of batteries.

I'm lost. :walterpeck:
#4971112
Looking at the picture closely, it looks identical to a Tamiya Light Dash, as opposed to the Light Dash Pro (double shaft) or Hyper Dash (high rpm & red color cap).

If you get the motor out of there, care to take a few closeups for the rest of us? Matty may even have left the Tamiya sticker on it.

In fact, you could even experiment by installing a Hyper Dash in there for more beefy vibration, although I don’t know how well the plastic gears would hold up.
    Hello

    http://i.imgur.com/1kB7fOZ.jpg

    I mean... if Michigan Ghostbusters can upload t[…]

    Happy to be wrong, but I don't think Celeste will […]

    Animated Vigo "painting"

    GO COOL! Very cool! I'm working with a local non […]